csmaro

Po instalacji systemu występuje problem z wirtualnym pulpitem Debian 8 [x64]

3 posty w tym temacie

Czesc

Mam VPSa z Debianem 8 x64. Instalowałem według tego poradnika(spoiler)

Spoiler

Autor: Mezir

1. Na początek odświeżmy listę repozytoriów w tym celu użyjmy polecenia apt-get update

2. Kolejnym krokiem jest instalacja środowiska graficznego gnome. Aby je zainstalować używamy komendy apt-get install gnome Cała instalacja trwa, to dość długo w międzyczasie możemy skoczyć po coś dobrego. :P

3. Gdy instalacja zostanie ukończona instalujemy vnc4server poleceniem apt-get install vnc4server tym razem, to nie długo.

4. Uruchamiamy vnc4server poleceniem vnc4server :1

5. Po uruchomieniu zostaniemy poproszeni o utworzenie hasła, więc wpisujemy nasze hasło po czym zatwierdzamy enterem.

6. "Zabijamy" proces vnc4server poleceniem vnc4server -kill :1

7. Teraz przechodzimy do katalogu root/.vnc i edytujemy plik xstartup

8. Na samym końcu w nowej linijce dopisujemy gnome-session & i zapisujemy całość.

9. Uruchamiamy vnc4server ponownie poleceniem vnc4server :1

Aby połączyć się z Naszym pulpitem potrzebujemy programu VNC Viewer for Windows pobierzemy go z TEJ strony.

10. Włączamy go i uruchamiamy, w okienku VNC Server wpisujemy IP naszego serwera wraz z portem 1 na końcu (przykładowo 111.222.333.444:1).

11. Klikamy "Connect". I w tym momencie powinniśmy się połączyć z pulpitem Naszego serwera.

 

Gdzie przeznaczenie to debian 6/7(moze jak pisał to nie było jeszcze 8 nie wiem. Ale nie bangla mi coś.

Jak się łącze przez VNC pokazuje mi się

Spoiler

35be748116e842a69f9530f5cbb506e9.png

Zamiast normalnego pulpitu debianowskiego :)  Ktoś coś? jakaś pomoc?

 

VPS to:

8fc3bab7ff97473da8ef68afbb617f86.png

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

>gnome na 1 gb ramu i na VPS - niewypał. Wolałbym na twoim miejscu zainstalować coś lżejszego (na przykład LXDE) poprzez komendę apt-get install lxde i do ~/.vnc/xstartup bym dodał następującą zawartość:

lxterminal & /usr/bin/lxsession -s LXDE &

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Ja się uporałem z tym dzisiaj i to 3'ma komendami 

 

apt-get install dialog
apt-get install whiptail
apt-get install libgd2-xpm

3 maj mam nadzieję że pomogłem :)

2 osoby lubią to

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Napisano przed chwilą

North-Host.pl

Żeby dodać komentarz, musisz założyć konto lub zalogować się

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Rejestracja

Załóż nowe konto. To bardzo proste!


Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz