Obserwujący 0
FateBoy

Nie wyświetla avatarów

3 posty w tym temacie

Link do forum: www.headmania.xaa.pl

Dokładny opis problemu: przy ostatnim poście nie wyświetla avatarów

Posiadany styl: deflection

Modyfikacje na forum:

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Musisz to sobie sam ustawić.

Tam chyba jest instrukcja, a jak nie to wystarczy trochę ruszyć mózgiem.

przemo.org/phpBB2/forum/viewtopic.php?t=105582

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Tamo, jak zainstaluje to , to będzie miał dwa jedno działające a drugie to co ma .

FateBoy, użyj tylko tego .

#Otwórz (OPEN) incudes/functions_hierarchy.php

#Znajdź (FIND):    

// last post

#Przed dodaj (BEFORE ADD):

// last avatar

if ( $data['tree.topic_last_post_id'] )

	{


$sql = "SELECT user_id , user_avatar, user_avatar_type, user_allowavatar

	 FROM " . USERS_TABLE . " 

	WHERE user_id = '".$data['tree.post_user_id']."'";

if ( !($result = $db->sql_query($sql)) )

{

	message_die(GENERAL_ERROR, 'last avatar', '', __LINE__, __FILE__, $sql);

}


$avek = $db->sql_fetchrow($result); 



$last_post_author_avatar = '';

if ( $avek['user_avatar_type'] && $avek['user_allowavatar'] )

        {

            switch( $avek['user_avatar_type'] )

            {

                case USER_AVATAR_UPLOAD:

                    $last_post_author_avatar .= ( $board_config['allow_avatar_upload'] ) ? '' : '';

                    break;

                case USER_AVATAR_REMOTE:

                    $last_post_author_avatar .= ( $board_config['allow_avatar_remote'] ) ? '' : '';

                    break;

                case USER_AVATAR_GALLERY:

                    $last_post_author_avatar .= ( $board_config['allow_avatar_local'] ) ? '' : '';

                    break;

            }

        }

        else

        {


          if ($avek['user_id'] == '-1')

          {

            $last_post_author_avatar .= '';

          }

          else

          {

            $last_post_author_avatar .= '';

          }



        }


  }


#Otwórz templates/NazwaStylu/NazwaStylu.css

#Znajdź (FIND): 

/* General font families for common tags */

Przed  dodaj (BEFORE ADD):

.avatar { width: 40px; height: 40px; border: 1px solid #666666; padding: 3px;  -moz-border-radius: 5px; border-radius: 5px; }[/code]

tylko te 2 punkty wystarczą i będzie ok .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Napisano przed chwilą

Ceesik.pl

Gość
Ten temat jest zamknięty i nie można dodawać odpowiedzi.
Obserwujący 0